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I. Discover the features   
A.  3D view 
1. Preview (Display of the 3D view) 

In the menu bar, a drop-down menu allows you to control what you see in 
the 3D view. 
 

 
 

• Preview all : all is displayed 
• Preview tabletop : preview of the tabletop display 
• Preview selection : displays only the objects in the selection 

list 
• Preview checklist : displays only the objects in the checklist 
• Preview visibility list : preview a visibility list 

2. Camera controls  
 

Rotation: left click and drag the mouse 

 

Shift of the point of view : right click + mouse movement 

 

Zoom: mouse wheel 

 

In Orbit mode the rotation is done around the point of view, in Fly mode the camera 
turns on itself 
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3. Center view 
Center the view to return to the initial state. 
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4. Quick view display (top, bottom, side view) 
Click on the camera icon to display a specific view quickly. 
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 : Show a 3D view from above 

 :  Show 3D view on the left side  

 :  Show 3D view from the right side 

 :  Show 3D view from below 

 

B. Selection  
 

The selection list allows you to perform actions on several objects at the 
same time.  
To add or remove objects from the selection list, there are several options : 
 

• Via the context menu of an object in the Hierarchy window 
or in the 3D View 

• By left-clicking on an object in the 3D View while holding 
down the CTRL key 

• By doing a Search 

Once the selection list contains objects, the different actions available are displayed 
in the Selection window. 
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➢ “Remove all selected objects from output", allows to remove objects 

when generating .nbim 
➢ “Create new checklist with default state", allows to convert the 

selection into a checklist  
➢ “Add new material to objects”, allows to color the selected objects  
➢ “Create new visibility list with selection", allows to create a visibility list 

corresponding to your active selection. 
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1.  Select an object from the model 3D 
To select an object from the model, right click on the object in the model > "Add 
object to selection” 

 
  

 

The selected object is added to your selection  
 

 
 

Selected objects are highlighted automatically.  

In the "Selection" panel, change the highlighting color by clicking on the color box or 

uncheck the " " icon to disable the highlighting color on selected objects (we 
recommend that you leave this feature active). 
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2. Multi-selection 
To be able to select objects simultaneously, hold the "Ctrl">left click key on the 
objects you want to select. 

These objects are added to your selection automatically. 
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By holding down "Ctrl" + left click, you can make a selection area and select multiple 
objects at once. 
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All selected objects are now highlighted and displayed in my selection at the bottom 
left of the screen (756 objects in selection). 

3. Display my selection  
View your selection in the 3D view : Preview all > Preview selection 

Create a selection :  

With a selection box CTRL + Left click 
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Preview selection :  

 
 

View of the selection :  
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Or with the “Menu Edit>Find” tool. 

 
Add your search to your selection by clicking on "Append” 
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Result of the view of our selection: All objects containing "Door" in their name.
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C. Inspect 
To inspect an object, click on it with the left mouse button. It is displayed in blue and 
the Hierarchy scrolls to that object. 

 
 

Double click on the object in the hierarchy to center it in the 3D View. 

 

Right click on an object to access its contextual menu (on the object in the 3D view 
or in the hierarchy)
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D. Files 
1. Formats 
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➢ IFC : The .ifc format is the only format that can be converted by NEXT-BIM 
 

➢ .nbim : This is the format to import in the document folder of your Hololens 2. 

 

➢ .nbim_preconfig : Allows you to save the configuration created during a 
project to be able to reuse them in a new project.  
 

➢ Nbim_project : this is the registration of your project on your PC with the 
corresponding configuration. 

 

Note : all configurations (annotations, control lists, visibility lists, tabletop etc..) can 
be saved separately. In the desired configuration menu, click on file > Import/Export 
NEXT-BIM ...X... (annotation/checkllist, tabletop....) Configuration File  

 
 

 
 

 

2. Open a file 
 

Go to Menu File> Add .ifc / .nbimprocessed 
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Select the .IFC files you wish to import or .IFCzip file

 
When you first open the program, it triangulates the file. Wait for the triangulation to 
finish before using the features. 

 

 

On the second opening, the file will be imported from the cache area. Thus, 
triangulation does not take place and the loading time will be shortened. 
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3. Open an existing project 
To open an existing project, Menu File > Open project > select the project file you 
want to open in your file explorer.

 

4.  Import/export a configuration (.nbim_config) 
To save the configuration, go to Menu File>Import/export configuration file>Export 
full configuration file 

 
The export allows you to save this configuration on your PC in order to apply it to 
other projects. The import allows you to import the configuration saved on a project.  

To import a configuration from an old project, go to Menu File>Import/export 
configuration file>Import full configuration file>choose in your documents the 
desired nbim_config. 
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5.  Generate the file for NEXT-BIM Explorer (generate .nbim) 
Go to Menu File > Generate NBIM 

 

 
Save the file to your computer in the desired location 
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E. Windows  
1. Hierarchy – File tree structure 

The different open files appear in your hierarchy.  

Click on the file to open its hierarchy.  

 
Click on the storey to open its hierarchy = Objects 
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To close ALL drop-down lists, click on "Collapse All". 
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a) Show / Hide File/Storey/Object  
 

Hide / Show a file 

To hide a file, click on the eye to the right of your file to hide it.  

 

There is a difference between "Hide" and "Remove objects", (see here) 

 
                 

 

The icon              is crossed out when the file is hidden. 
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To redisplay the file/storey/object, click on the crossed-out eye icon  

 

Hide / Show all the files  

This feature is useful if you have many files and want to view one or two of them. 
Hide all files, then click on the file(s) you wish to view.  

 

Hierarchy > "Hide All files 
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Hierarchy > “Show all files” -  redisplay all the files 
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b) Hide / Show an object    

To view the objects in the file, click on the arrow of the file in the hierarchy and click 
on the floor where the object is located. 

Right-click on the object in the hierarchy, then click on  to hide it. 
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The object is hidden 

 

To redisplay the object, click on the icon  at the end of the object's line. 
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OR 

 

Windows>Hidden Object>

 

Click on the icon  of the object 

 
The object is re-displayed.
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2. Contextual Menu in the Hierarchy 
a) Center camera on an object  
 

To center the camera on the selected object : Right click on the object in the 
hierarchy> "Center camera on object” 
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b) Remove an object from the .nbim file from the Hierarchy  
 

To remove an object from your file (.nbim – NEXT-BIM Explorer) from the hierarchy   
Right click on the object > "Remove object from output". 

 
 

Once the object is crossed out in the hierarchy, then the object will not be loaded in the 
.nbim format. 
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To see all the items that will not be loaded and modify this list, see here  
 
Other features are available in the context menu of an object : 

 
➢ Add in selection = Add this object to your selection  

 
➢ Table top : Remove " X " Type from output = Remove the Type (ifcclass) from the 

reduced model mode  
 
➢ Material : Add new material to object = Only colour this object 

 
➢ Material : Add new material to ifc(type) = Allows to colour all objects of a Type.  
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➢ Checklist : Add object to checklist = Available if a checklist has been previously 
created. Allows you to add the object to your checklist. 

 

 

➢ Visibility list = Available if a visibility list has been previously created. Adds the 
object to an existing visibility list. 

3.  Properties 
In the “Properties” window, view the properties of the inspected object 
(displayed in blue in the 3D View). 
 
Menu Windows > Properties  
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4. Hidden Objects  
Find all the objects you have hidden. 

Menu Windows > Hidden Objects 
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The list of all the objects you hide will appear. To redisplay an object, click on the “ 

” icon  

To unhide all objects, click Un-Hide all. 

 
 

5. Filters  
Creating filters allows reapplying its filters on your future configurations and 
therefore not wasting time on your future projects. It is important to take the time to 
think generic when creating your filters. The more specific and generic the filters are 
when they are created, the faster future configurations will be. The sorts by 
properties are very interesting to be precise if you use these same properties on all 
your projects. Filters allow you to sort your objects to apply Configurations to them 
(Checklists, materials, Tabletop, etc.) or add your targets for the quick re-alignment 
tool by targets. 
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Menu Windows > Filters  

 

 
 

The library on the left “Project filter library” saves the filters for this project only. If 
you save a filter in this column, it will be saved in the library of the current project 
and will not be found when opening a new project. The library on the right “Shared 
filter library” stores filters for all projects. If you save a filter in this column, it will be 
saved in the library of all your projects. When opening a new project, this filter will 
be accessible and therefore applicable. 
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The "+" button allows you to create a filter in the desired library.

 
When creating a filter, rename your filter (example: Door level 1). 

 
 

You can create multiple rules and multiple rule sets. Rulesets can be nested. The 
number of rules and rule sets you can define is not limited. Define your filter rules 
carefully using AND and OR conditions, as well as nesting, to ensure that you get the 
desired result.  

Tip : Create a sample template containing items with the categories you want to use 
in the filter. Try creating filters using rules and applying the filters to views until you 
get the desired result. Add a sorting rule with the "Add new rule" button 
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a) Filter based on rules  

➢ Name rule : : allows to sort with elements of the name of the object  
➢ Type rule : allows you to select one or more .ifc classes  
➢ File rule : allows to select files 
➢ Storey rule : allows to select building level 

Object property rule : sort objects by their properties 

b) Filter based on a selection  
 

Object list rule : allows you to add the selection created 

Caution: Creating a filter from a selection does not allow this filter to be reapplied to 
another project. 

c) Invert my rules / Reverse his rule 

Each rule can be reversed to select the opposite of what is indicated : 
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Click on the name of the rule to reverse a rule (example: click on “Name contains” to 
apply “Names does not contain”). 

d) EXAMPLE “AND” condition filter  
 

The "AND" condition allows you to combine rules to be precise in your searches. The 
use of "AND" means that all applied rules must be true.  

Example: we want all doors on the first floor to be 0.915m wide doors.  

Use “type rule”, “storey rule”, “object property rule”  
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Type rule : class ifc door, 

Storey rule : First floor (niveau 1),  

“Property name” : width 

“Property value”: 0.915 
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Press “Back” once your filter is complete 

 
 

Preview your filter by clicking on the “Preview filter” icon 

 
The total number of objects in the filter is displayed at the end of the line 

e) Create a nested filter (contains different objects) 

Use the "Rule group" rule to include different types of objects in a filter. 
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Menu Windows > Filters > Add new rule > Rule group  

Example :  

➢ We want to add the level 1 windows in addition to the level 1 doors, of 
0.915m. 
 

➢ We transform our previous filter (level 1 gate of 0.915m) into a nested filter 
(rule group).Appliquer une règle général en « OR ».  
 

➢ Now we want the windows of level 1. Add a nested rule “rule group”. 

 

➢ Add a rule by type (classifc) to select windows 

 

➢ Attention, it is necessary to take care that in your class ifc are present only the 
windows which you wish. Otherwise, you need another way to sort your 
different windows (property rule, name rule etc…). 
 

➢ Then, add a rule per storey (floor) 
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Result : 

 

 

F. Condition ET (AND) simple 
 

 

 
Lorsqu'un jeu de règles utilise la condition ET, toutes ses règles et tous ses jeux de règles imbriqués 
doivent être vrais. 

 

 
 

 

https://next-bim.com/en/


                                                                                                                           

Find all support documents in your customer area : https://next-bim.com/en/..... 

 

 

 

f) OR Condition  
 

 
When a rule set uses the OR condition, one or more of its rules or one or more of its 
nested rule sets must be true. If you want to select multiple values for the same 
parameter, add a rule for each value. Nest these rules under a rule set with an OR 
condition. 

g) Nested rule sets (“Rule group” with “AND/OR”) 
 

When filter rules include nested rule groups, use AND and OR conditions carefully, in 
the correct order, and with proper nesting. For some results, you must use AND with 
a nested OR condition. For other results, you must use OR with a nested AND 
condition. Results can vary widely, and you should be careful to use the correct filter 
rules to achieve your goals. 
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G.  Settings 
 

1. Default configuration 
Allows you to set the current configuration as the default configuration when 
opening NEXT-BIM Configurator 

2. Cache 
 

When an .ifc file is first loaded, it is converted to an .nbim_preprocessed file and placed 
in a cache folder.  

The next time the same .ifc is opened, the .nbim_preprocessed file is reused instead 
of having to redo the conversion.  

The location of the cache and its maximum size is configurable in the Menu Settings > 
Cache 

 

We advise you not to go below the default maximum size of 8 GB for 
comfortable use. 

 

To manage your cache area, go to Menu Settings > Settings… > Cache 
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a) Clear your cache 

To clear its cache, Cache> “Clear entire cache”Pour vider son cache, Cache> “Clear 
entire cache” 

 

 

https://next-bim.com/en/


                                                                                                                           

Find all support documents in your customer area : https://next-bim.com/en/..... 

 

 

 

b) Inrease your cache storage capacity 

To increase the storage size of its cache area, Cache > Drag the bar ”Maximum 
cache size” 

 

 
 

 Note: the cache area is automatically updated if the weight of the cache area 
exceeds the defined weight (“Maximum cache size”). The cache update is 
done from the oldest file to the newest. 

 
 
c) Change destination of .nbim_preprocessed files 

 

Pour changer la localisation de ses fichiers .nbim_preoprocessed sur son ordinateur, 
Cache > Change Location 
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H. Edit  
 

1. Find - Perform a search  
Search (via Edit>Find...) allows you to build a selection list by performing searches 
for objects based on one or more criteria such as their name, their type, their floor, 
the .ifc file or their properties. 

 

2. Create a selection of objects using the “Find” tool 
You can directly search for objects and apply "filters" to this search 

Go to menu Edit>Find  
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You can search for your objects by their full or partial name, i.e. if the object is called 
“M_Upper Cabinet – Single Door - Wall”, by searching for “Door” in “Name” all objects 
including “Door” in their name will appear. 
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67 objects including the word “Door” were found. To find the “M_Upper Cabinet – 
Single Door – Wall” doors, repeat the search by name with “M_upper” for example 
by clicking on “update result”.
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To add them to our selection, click on>Append. If a selection is already active, click 
on “Replace” to replace the selection with your last search.

 
 

Once added the “Selection” window opens automatically. Selected objects are 
highlighted. You can remove the highlight color or change it by clicking on “Highlight 
selection” To perform a second search, return to the Edit>Find tab and click on the 
“+” button. 
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3. Filter your searches by properties 
 

To apply rules to find objects by properties, Edit>Find and click on the “Add rule” 
button 
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Three property filters are applicable by set name, by name, by value. 

 
Enter the corresponding Property: Set name / Name / Value to search for objects. 

IMPORTANT: If you create a filter from your selection (Object list rule), the 
configuration created from this filter will not be reapplied to another project. 
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I. Configuration  
1. Annotations 
 

Configure your annotations 

Annotation editing is available in NEXT-BIM Explorer, however the virtual keyboard 
of the HoloLens is less ergonomic than a computer keyboard, that's why we 
configure the annotations here. To configure its annotations,  
Configuration>Annotations

 
 

 
a) Add / Delete a recipient  

In the first "Recipient List" tab, add/delete recipients (Subcontractor, model manager, 
etc.) of the annotations.
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To add a recipient click on “Add” and add the recipient(s) verbatim.

 
To delete a recipient, click on the trash can icon to the left of the recipient's name.

 
b) Edit titles and comments (annotations) 

You can configure annotation titles and comments. We advise you to identify your 
uses with their recurring problems and to make a list adapted to your recurring 
problems. Example: For a booking check at runtime, bad placement can be a 
recurring problem, so add a title "bad placement" and a comment "Element is not 
placed correctly". 

 

   The “+ Add” button allows you to add a new title coupled with a new 
comment. 

   The trash icon allows you to delete a predefined title and comment. To modify 
the content, simply replace the existing text    

https://next-bim.com/en/


                                                                                                                           

Find all support documents in your customer area : https://next-bim.com/en/..... 

 

 

 

Tips :  

#1: For the last annotation, it is better to leave a “to be completed” box. This box will 
be useful in the event that a problem had not been imagined. On site, select this 
comment and the problem will be modified from your management platform (BIM 
Track, BIM Collab, Solibri, AxeoBIM, etc.) or on an Excel, using the photos taken 
during the annotation  

#2: It is preferable to restrict the lists of annotations according to specific uses and to 
create several lists according to the uses. 

c) Configure your status (annotations) 

Annotation statuses represent the evolution of your issues. Colors are associated 
with statuses. As a reminder, the numbered pads of the annotations are visible in 
immersive mode or in tabletop mode in NEXT-BIM Explorer. The colors allow a quick 
understanding of the status of the problem. 

Menu Configuration > Annotations > Topic Status 

 
By default three statuses are available.  

add/modify/delete statuses according to your process. 

Example :
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To add button “ + ADD”   

To remove trash can icon  

 Modify the colors of the statuses by RGB codes or using the color palette by clicking 
on the colored square 

 
 

Tip : Keep the statuses and comments of your collaborative management platforms 

d) Recover/Export annotations (.bcf or .xlsx + .jpeg files) 

Annotations are exported from the Annotations tool in NEXT-BIM Explorer. Then, the 
.bcf files are to be imported on the computer by connecting your PC to your 
HoloLens (USB or Windows Device Portal). Once your .bcf exports have been made 
and imported on your PC, import your .bcf files into a BIM collaborative management 
platform to transmit the problems to your collaborators and deal with the problems.  

Coming soon: reimport your .bcf in NEXT-BIM Explorer to view only untreated issues 
more easily. 
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2. Explorer  
Configure your settings of NEXT-BIM Explorer 

The Explorer configuration allows you to activate the settings you want by default. 
Configuration menu > Explore 

 

Menu Configuration > Explorer  

 
a) Configure your interface :  

 
• "Generate Minimap": The generation of the minimap makes it possible 

to display the minimap in NEXT-BIM Explorer. If the function is 
deactivated, the minimap will not be available in NEXT-BIM Explorer, 
however the conversion of the .nbim file will be faster  

• “Show Minimap By default”: if the box is checked, the Minimap will be 
displayed as soon as you go into immersive mode.  

• “Show Voice Command List By Default”: Check the box to display the 
list of contextual voice commands in your holographic view 

b) Configure your visibility   
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• 15m / 25m / 50m Default view distance : Select the NEXT-BIM Explorer 
default view distance. We recommend 15m especially if your files are heavy 
and dense and you are on construction site 
 

• “Show All Floors By Default”: Activate the function only if you want to 
perform visualizations through a floor or if when using the Checklist, objects 
are referenced on the wrong floors. 

c) : Configure your complementary tool to continuous alignement  -> Quick 
re-alignment by targets: 

 

Create a filter containing all the targets that you have previously modeled (CF NEXT-
BIM Explorer Video Tutorial Rapid realignment by targets). Filter by name or files 
according to your choice.

 
 

3. Checklist 
SEE HERE 

4.  Visibility list 
Quickly show/hide objects, types (IFC), files in NEXT-BIM Explorer via visibility lists. 

To create visibility lists, Menu Configuration>Visibility list (see here) 
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Materials (colors) 

The configuration of object colours is important to improve visualisation AND 
understanding in the helmet. 

To change the colours, Configuration Menu>Materials  

 
 

You can change the colours by object, by IFC type or by file (see here) 

For a better visualisation, we recommend the following colours: 
 
 
 

Several shades are possible and test other colours to see which ones suit you best. 
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5. Tabletop 
a) Configure your reduced model  

Tabletop mode is the scale model in NEXT-BIM Explorer that lets you position in the 
building to switch to 1:1 scale. It appears as soon as the .nbim file is opened. In the 
Tableop model, we can't load all items because we're limited by the performance of 
the HoloLens. Thus, it is possible to load 1 million “triangle”. So, a default 
configuration was set up with a priority rule by types.  

Note : Slab and wall are mandatory to be able to immerse yourself in the model. To 
configure Tabletop mode, Configuration>Tabletop tab 

To prepare your Tabletop mode, Menu Configuration > Tabletop 
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The "Whitelist" is the list of IFC types that we will view in Tabletop mode, whereas 
the IFC types in the "BlackList" will not be imported. The Type list on the left is the 
white list. The list on the right is the blacklist: The "Whitelist" is the list of IFC types 
that we will view in Tabletop mode, whereas the IFC types in the "BlackList" will not 
be imported. The Type list on the left is the white list. The list on the right is the 
blacklist: 
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To change a list IFC type, simply click on the type button.

 

https://next-bim.com/en/


                                                                                                                           

Find all support documents in your customer area : https://next-bim.com/en/..... 

 

 

 

The number of triangles that can be imported into the whitelist is displayed at the 
bottom left (e.g. 920.235). 

 
Ifcflowfitting exceeds this limit, that is why the type is displayed in red. You can still 
switch the type Flowfitting to the white list 0.235). 

https://next-bim.com/en/


                                                                                                                           

Find all support documents in your customer area : https://next-bim.com/en/..... 

 

 

* 

 

 

 

 

 

 

 

 

 

 

 

 

However, ifcflowfitting will not be displayed in tabletop mode. A warning message 
appears "everything below this point will be ignored.....".  

In this case, you still have the remaining number of triangles of 920,325. 
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To display IfcFlowfitting, you can move the type up by clicking on the "up" arrow 
until it is no longer in red. 

  
All items below the ifcflowfitting will no longer be displayed in tabletop mode in 
HoloLens.. 

b) Filters tabletop  

The purpose of the filters for tabletop mode is to display in the HoloLens objects of a 
Type that exceeds the 1 million triangle limit.  Whether the type exceeds 1 million 
triangles on its own or the remaining limit does not allow the inclusion of a type 
exceeding this remaining limit.  

Configuration Menu>tabletop>Filters 
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Create & add new filter, allows you to create a filter for the tabletop mode. 

For more information on filters, see here. 

Once your filter is created, it will automatically be added to your tabletop mode. 

The filter takes precedence over the classification of your types (classifc).  

6. Storeys 
Reorganise your hierarchy by levels. This feature has several interests. Firstly, to 
perform a cut by floor, this hierarchy facilitates this action (see here). Secondly, if 
your .ifc files do not include a storey organisation, you can do this directly in NEXT-
BIM Configurator.  

Configuration menu > Storeys  
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Reorganise all your files with one click 

Reorganise only a file f  

Your new hierarchy is available: Windows Menu > Hierarchy > Storey
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7. Removed Objects 
 
To see all the items that will not be loaded and modify this list, go to : 
 
Configuration>Removed Objects 

 

  
 

The list of all elements that will not be loaded appears (all objects where you have applied 
"Removed object/Types/Storey/Files from output 

 

 
To put the object that was deleted back into the final file, click > "Re-add" on the desired 
object or > "Re-add all" to put several objects back with one click. 
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 If you have deleted remote objects so as not to interfere with the 
conversion of your .nbim file, these objects should be in this list 

 

 

8. Property filtering (Importing properties) 
 

II. Useful information 
A.  Poor geo-referencing of mock-ups  

When exporting .ifc files, check the geo-referencing parameters so that your 
different .ifc files are superimposed.  

 

B. Why are there two executables, Converter.exe and 
Configurator.exe? 

Before NEXT-BIM Configurator was released, there was only NEXT-BIM Converter 
to convert 

.IFC files to .NBIM format. Following its development NEXT-BIM has developed 

this new tool, NEXT-BIM Configurator to prepare and configure its immersion. At 

generation of the .NBIM format in NEXT-BIM Configurator, it is NEXT-BIM 

Converter handles the conversion. 

 
C. Conversion time 

The conversion time depends on the file size and the processor of your computer. 
The more powerful your computer, the faster the conversion. The lighter your file, the 
faster the conversion. 

The generation of the minimap affects the conversion time. Deactivate the option to 
convert your .NBIM faster. 

Configuration tab > Explorer > Interface > "Generate minimap 
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D. Differentiate between "Remove Object from 

output" and "Hide Object 
"Hide Object" is a "visual" function, it allows you to hide this element when viewing 
andyour visualization and preparation of files, but when you dip the object will be 
visible. However, you can not load the object in the helmet with the “Remove Object 
from output" function. 

Why not load an object or object type? 

Optimising your immersion: Your file is already very heavy, and you need to 

need to improve the smoothness of the view. You can remove all the elements 

not necessary for your use to improve the performance of the software 

Remove the parasite elements that can disturb your use/experience 

E. GUID Conflict 
If a black triangle appears to the right of your files, they are objects with the same 
GUID on two different files. 

 
 
 

Here, the objective is to remove the conflicting objects from the project so as not to 
have a visualisation problem in the Hololens. 
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Several options are available to you. 

>Right click on the triangle :  

• Add conflicting objects in this file to selection" adds the objects to our 
Selection”. 

 

• Add conflicting objects from other files to selection" adds conflicting objects 
from the other file to your selection. from the other file to your selection. 

 

But the faster options for removing objects from the project are at the bottom. 

• “Remove conflicting objects from this file from output" removes the objects 
from the file where the right click was made from the project. 

• “Remove conflicting objects from other files from output" allows you to 
remove from the project the objects in the file that conflicts with the one 
where the click was made. 

 
 

 

F. IMPORTANT BEFORE NBIM CONVERSION  
See here: Cleaning up the model 
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III. Putting it into practice: Configuring your NBIM file 
A. Open your .ifc / .ifczip files 
1. files : add .ifc 

Import your .ifc files into your project.  

File>Add .ifc / .nbim_preprocessed 

 
Select the .ifc or .ifczip files you wish to import in your file explorer 
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2. Rename your .ifc  
Rename your files by engineering design to make them easier to use in NEXT-BIM 
Explorer. 

  
Hierarchy> Right click on the file > Rename according to the engineering discipline ( 
hvac, elec...) 

https://next-bim.com/en/


                                                                                                                           

Find all support documents in your customer area : https://next-bim.com/en/..... 

 

 

 

3. Cleaning up the model  
The cleaning of the model is a compulsory step in order not to have a lag in tabletop 
mode (display above the blue circle or model too small) and also for your future 
conversion to .nbim. All objects far from the centre of the project will disturb either 
the tabletop display or the conversion to .nbim. 

To clean up your model, follow these two steps:  

1) Display your model in top view. 
 Click on the camera icon  

Display your model in top view. Click on the camera icon  .  
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Click on the "down" arrow 
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Make a selection box as close to the edges of your 3D model as possible: Hold Ctrl + 
Right Click  

Once your model is selected, the selection will be displayed in yellow in the highlight 
colour. 
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Open the selection panel by clicking on "X objects in selection » 
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Invert your selection, all objects that are not in your selection box will be selected 
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Click on "Remove all selected objects from output" to remove all unwanted 
objects. 
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Then repeat the operation with a side view. 

 
 

B. Trimming your model (necessary in large and dense 
files) 

To improve the performance of NEXT-BIM Explorer in very large models, it is 
advisable to cut your model according to its use. For example, if you are checking at 
level 1, other levels may not be necessary, or if a component is not required for your 
use, delete it. 

To cut your model, there are several possibilities. 
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1. Use the Find tool to add the part of the model to be imported to 
your selection box.  

(In this way, your .ifc files must be classified by technical.) 

 
In this example, we only want to import level 1 of the building, and you do not want 
to include some of the engineering disciplines (MEP).  

Select the Architecture and Structure file from the "Files" drop-down menu 

 
Select the first floor, for information the search will be done in all the storey of the 
first floor despite the display by files. 

» 

The number of items in the search appears in the "results" box 

To add this search to your selection, click on "Append". 
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The selection window will open automatically. To view your selection, click on 
"Preview selection". 
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We want to keep this level 1. We will invert our selection to remove the objects from 
our selection.  

Click on "invert selection". 

 
 

 

Finally, remove the objects from your project by clicking on "Remove selected objects 
from output". 

Your cut is finished. 

note: The deleted objects are kept in your Configuration>Removed Objects tab. (See 
here) 

 

2. Use the Storey Configuration Tool to reorganise your hierarchy 
by level and perform a level cutout of the model. 

 The Storey Configuration Tool allows you to create a new hierarchy by level (see 
here) 
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 The level indicated in your CAD software will be the one kept by the storey 
management. 

 

Example: if a duct passing through two levels (level 01 and level 02) has been 
referenced on level 01, the storey management will take this reference into account 
and will not appear in level 02.  

 

Once your Storey Configuration is done, go to Windows>Hierarchy>Storeys 

Finally, remove the objects from your project by clicking on "Remove selected objects 
from output". 

 

 
 

We want to import level 1 and level 2.  

Hide the other levels (Roof-main and TOF footing) by clicking on the "eye" icon of 
the relevant levels. 
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Make a selection box (CTRL + Right Click) of the current visualisation. 
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Re-display hidden levels by clicking on the "crossed out eye" icons.

 
Open your selection by clicking on "X objects in selection 

 
 

Invert your selection 
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Finally, click on "Remove all selected objects from output".  
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3. Preparing your tabletop model: Tabletop configuration 
1. Configuring your tabletop mode 

The tabletop mode is the model in the helmet that allows you to position yourself in 
the building to immerse yourself in a 1:1 scale. 

position yourself in the building to immerse yourself in the 1:1 scale. It appears as 
soon as you open the .nbim file. 

In the Tableop model, we cannot load all the elements because we are limited by the 
performance of the HoloLens. Thus, it is possible to load 1 million "triangles". So, a 
default configuration has been set up with a priority rule by types. 

To know: Floors and walls are mandatory to be able to immerse in the model. 

To configure the tabletop mode: Configuration Menu>Tabletop
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The "Whitelist" is the list of IFC types that we will see in Tabletop mode, whereas 
the IFC types in the "BlackList" will not be imported. The Type list on the left is the 
white list. The list on the right is the blacklist. 
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To change a list IFC type, simply click on the type button. 
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The number of triangles that can be imported into the whitelist is displayed at the 

bottom left (e.g. 920,235 triangles remaining) 
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Ifcflowfitting exceeds this limit, that is why the type is displayed in red. You can still 
switch the type Flowfitting in the white list. 

However, ifcflowfitting will not be displayed in tabletop mode. A warning message 
appears "everything below this point will be ignored....." . 

In this case, you still have the remaining number of triangles of 920,325. To display 
IfcFlowfitting, you can move the type up by clicking on the "up" arrow until it is no 
longer in red. 
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4. All items below the ifcflowfitting will no longer be displayed in 
tabletop mode in HoloLens. 

 

5. Filters tabletop  
 

The purpose of the filters for tabletop mode is to display in the HoloLens objects of a 
Type that exceeds the 1 million triangle limit.  Whether the type exceeds 1 million 
triangles on its own or the remaining limit does not allow the inclusion of a type 
exceeding the remaining limit.  

Configuration>tabletop>Filters 
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"Create & add new filter" allows you to create a filter for the tabletop mode. 

For more information on filters, (see here). 

At the start of our example above, the .ifcflowfitting types exceed the remaining 
triangle limit (927,322>920,235). We can create a filter containing a list of an object 
type or types of .ifcflowfitting objects so that we can import them without changing 
the priority we wish to apply.  

Once your filter is created, it will automatically be added to your tabletop mode. 

The filter has priority. 

 

C. Colouring your model: Configuration materials 
1. Recommended colours 

 

For a better visualisation, we recommend the following colours: 
 

  

  
Several shades of these colours are possible. 

 

 

  A prioritisation of the colours is applied. The priority rule is: 
objects>filters>types>files. To illustrate, if we change the colour of a 
single object to red (example: a wall) and then change the colour of an 
IFC type (Ifcwall) to blue, the colour (blue) assigned to the object (the 
wall) is retained and has priority over that applied to the type (red). A wall 

will appear in blue and the others in red. 

To change the colours, go to the Configuration>Materials tab 
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2. Changing the colour  
To modify the colour, select directly on the colour palette tool or apply your RGB 
code 
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3. Change the transparency 
The "Preserve Opacity" checkbox is checked to preserve the original transparency. 

 
 

To change the transparency, uncheck the "Preserve opacity" box and adjust the 
"1.000" slider to the desired value (hold the click on the bar and move the mouse to 
the left to decrease the value) 
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4. Colouring by files  

Go to Configuration>Materials>Materials by file > Add

 
Select the file you wish to configure by clicking on the box corresponding to the file. 

 
 

We apply a colour to the "Clinic_A" file. 
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To change the colour of the file, click on the "Color" box  

Then apply the desired colour via the RGB codes or the colour palette tool.

 
To apply a colour to another file, click "Add" at the bottom and epeat the operation 
the operation explained above. 

 

5. Colour by type ( by type material - class IFC)  
 

Note: By default, two configurations already exist in the IFC types. We have added a 
texture to the walls and floors to improve visualisation. The colour of the walls and 
floors can still be modified.  
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To colour by type, go to the Configuration>Materials>By type 

material>Add 

 
After clicking on "Add" your IFC types are displayed on the right. 

https://next-bim.com/en/


                                                                                                                           

Find all support documents in your customer area : https://next-bim.com/en/..... 

 

 

 
Select one or more types by clicking on the corresponding box. Apply a colour with 
the palette tool or the RGB code to the selected type(s). 

To apply a new colour to one or more types, click on the "add" button. 
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6. Colouring by filters  
 

Configuration>Materials>By Filters>Add 

 
 

Apply a new colour from an existing Open Filter Library filter: 

 

➢ From an existing Open Filter Library filter: Drag&Drop the filter from the 
desired filter window into the "filters" column of "by filter material 

OR 
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➢ Create & add new filter: Create your filter (see here)  

 

Then click on the "Color" box to apply the desired colour with the colour palette or 
RGB codes. 

 
 

7. Colouring by object  
To colour by object, go to the Configuration>Materials>By Object Material>Add 

 

To add objects to your configuration you have several options. 

 

➢ Drag & Drop the objects from the hierarchy in the "By Object materials" tab  

OR 

➢ From the model: right click on the object>Materials>edit existing object 
material 
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OR 

➢ Set up several objects at once by including them in your selection list. 

Left click on the object>Right click on the object>Selection: Add Object 
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Open your selection tab at the bottom left of the screen. 
Windows Menu> Selection>Actions>Materials>Add new material to objects>Apply 
the desired colour  
 

OR 
 
Use the "CTRL" command to directly select several objects on the 3D view of the 
model 
Hold CTRL + Right Click.  
The selected objects will be highlighted. 
Go to Menu Configuration>Materials>By object> "Add Selected objects to list + " 
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Change the colour of imported objects with the colour palette or RGB codes. 

 
Add more object lists by clicking on "Add". 
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D. Preparing your controls : Configuration checklist 
1. Method 1: From an Excel file (from a plugin) (BIMone (revit) for 

example) 
 

The excel file can be created from a plugin like BIM One for Revit for example 

The Excel file created from your plugin should contain a column with the title GUID 
and the GUID of the objects, a column with title: object name and the name of the 
objects and in the third column a title: next-bim checklist or next-bim checklist with 
the default status (example: to be checked). 

2.   Method 2 : Prepare your checklist in NEXT-BIM Configurator 
Menu Configuration>Checklist 

 
 

 

 

 

 

 

https://next-bim.com/en/


                                                                                                                           

Find all support documents in your customer area : https://next-bim.com/en/..... 

 

 

a) Configure your states by default  

 
The first status (here “a verifier” = "to be checked") will be the initial status of the 
objects imported into the checklist when the checklist function is launched in NEXT-
BIM Explorer.  

To change the status, click on the text bar of each status and change the status by 
replacing the text. 

 
The status evolution in NEXT-BIM Explorer (when you click on an object to be 
checked in the HoloLens, the object goes from status n°1 “à verifier”="to be 
checked" to status n°2 "Ok" at the second click the status evolves from "ok" to 
"Invalid" etc...) corresponds to the order from top to bottom of the statuses in your 
checklist configuration 
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The arrows allow you to change the order in which the statuses evolve. 
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The colour assigned to the states can be changed by clicking on the "Color">Colour 
palette/RGB box. 

 
To add a new state, click on "Add new state". 

 

 
The default statuses will be applied automatically to all checklists unless you change 
the status settings in your checklist edit.  
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h) Create a new checklist  

Configuration>Checklists>New checklist 

 
Rename your checklist  

 
Customise your status for the list being created 
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This feature allows specific statuses to be applied for this checklist only. 

i) By object 

This method is adapted in case you create a selection with the "Find" tool or create a 
selection (CTRL+Right click)> "Add selected objects" in the "by objects" panel of 
your checklist tab

.  

 

 

Example: 
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Search for a door type in my "Find" tool

 
Add your result to my selection: "Append »

 
Add my selection to my checklist: Configuration>Checklist>By Object>Add selected 

objects 
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j) By filters  

 

Create filters (lists of objects) using sorting rules.  

This method is adapted in the case where your : 

➢ are located in a separate .ifc file allowing to apply a rule by "Files" in your 
filters 

OR 

➢ have a differentiating element in their names  
➢ a differentiation property in their set/name/value property  
➢ requires sorting by floor: rule by storey  
➢ Several objects of different natures: create rule groups with sorting rules by 

name, property, files, storeys etc...  
 

Rename your filter : 

 
 
Add your rules (by name, by type, by files, by property, by floor, by object list 
rule) to import the desired objects. 
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Closing your filter window 

 
Your filter has been successfully imported 

 

 

 

 

https://next-bim.com/en/


                                                                                                                           

Find all support documents in your customer area : https://next-bim.com/en/..... 

 

 

 
 

Rename your checklist  

 
 

 

Left your checklist 
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Your checklist has been created. 

 
 

E.  Preparing your annotations : Configuration 
Annotations 

Menu Configuration>Annotations  
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Two formats are available: the .xslx + jpeg format or the .BCF format, a 
communication format that allows the exchange of information or comments 
attached to a view or part of the IFC model. These annotations allow a stakeholder to 
be quickly notified about a specific topic concerning the project. 

Why create an annotation?  

- To create a view from a model or the real thing  

- Annotate the capture  

- Find all the information related to the annotation: recipient, status, comment... by 
importing your .bcf files into a collaborative platform.  Some platforms allow you to 
recollect the model directly via plugins.   

 

1. Add/Modify/Delete annotation recipients. 
Add: "+ Add" to add, then write the new recipient directly in the new line

 
Edit: click on the text bar and change the name of the recipient.

 
Click on the bin icon to delete a recipient. 
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Add the list of persons and/or companies that will receive annotations.

 
 

2. Titles / comments  
Menu Configuration>Annotations>Predefined comments 
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To modify an existing title/status, select the line and rewrite the title and status 
according to your uses.  

For example, in the execution control phase, define a title "Layout placement" with 
the comment "the element is not correctly positioned in the layout" and a second title 
"Site placement" with the comment "the element is not correctly positioned on the 
site".  

Tip: We advise you to leave a line with "To be completed", "problem to be 
completed" in case the problem has not been thought of before going on site. This 
line will be modified in your management platform or Excel file using the photo(s) of 
the annotation. 

3. Status  
A status indicates the state of the problem. It defines the chronology of a problem. 
The annotation dots in NEXT-BIM Explorer will be coloured according to the selected 
status.  

Change the colour of the status assignment here. Click on the "Color" box and 
change the colour using the colour palette or RGB code.
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F. Import only useful properties : Configuration property 
filtering  

The property filtering setting defines which properties you can display in NEXT-BIM 
Explorer via the information tool.  

Defining its use allows you to import only useful properties and not to have an 
endless list when using the information tool.  

To set up the property display: Configuration Menu > Property set  

 
Properties placed in the "Whitelist" column will be available in NEXT-BIM Explorer. 

Properties placed in the "Blacklist" column will not be available in NEXT-BIM 
Explorer 
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If you wish to import more properties than you wish to remove, click directly on the 
name of the property to move it to the 'Blacklist'.  

If you wish to remove more properties than you wish to import, click on "Transfer all 
to blacklist" and then click on the name of the properties you wish to import. 

G.  Create visibility lists: Configuration visibility list 
 

Create object lists to quickly show/hide objects. These lists are useful to facilitate 
viewing in NEXT-BIM Explorer according to your use cases. 

For example, you may only want to view the SANITARY networks and not the 
heating and ventilation networks. Create a list containing your structure + 
architecture + plumbing file. If the plumbing is integrated in an HVAC file. Use a filter 
to include the Structure + Architecture files with a rule per file and add a rule that 
allows you to identify objects related to sanitary, for example with a property rule.  

You are free to configure the visibility lists that are useful to you. 

Menu Configuration > Visibility list  
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1. Create a new visibility list  

 
Rename your visibility list to quickly identify it in NEXT-BIM Explorer. 
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2. Create a visibility list by Type / Class ifc (By Type) 
Select By type

 
 

The left-hand column corresponds to the types that will be displayed in the visibility 
list and the right-hand column corresponds to the types that will not be displayed in 
the list. 

The "Preview" box shows you the preview of your list in NEXT-BIM Configurator.  
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b) Create a new visibility list by files  

 
Check the box of a file to include it in your visibility list.

 
The "Preview" box shows you the preview of your list in NEXT-BIM Configurator. 
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a) Create a new visibility list by filter  

 
 

Create a filter or use an existing filter to create a visibility list with a filter. 

The "Preview" box shows you the preview of your list in NEXT-BIM Configurator.  

 

Example: 
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Step 1: Rename your visibility list 

Step 2: Create a new filter: "create & add new filter 

Step 3: Rename the filter  

Step 4: Apply rules to your filter 

Step 5 : Close the filter 
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"Preview”: Display your visibility list in the 3D view 

Back : End of the creation of your visibility list 
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H. Generate the .nbim file and import it into your 
HoloLens 2 

Before converting your file to .nbim format, make sure that the cleanup of the model 
has been done (see here). Then, launch the file conversion. 

Menu File > Generate .nbim 

 
Save the file in a folder on your computer. 
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To import this file into your Hololens 2, there are two possibilities:  

1. Import your .nbim file via your USB C device 
Connect your HoloLens via USB to your computer.  
Open your file directory on your computer. Click on the HOLOLENS device 

 
 

Go to  « Internal Storage » 
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Open the « Document » folder 

 
Copy your .nbim file to the "Documents" folder. We advise you to create one folder 
per project in your "Documents" folder.

 
 

 

2. Import your .nbim file via the Windows Device Portal 
Go to the Windows Device Portal via your IP address:  

Connect your computer to the same Wi-Fi network as your PC. 

Retrieve the V4 IP address of the HoloLens using the voice command "What is my 
IP? The IP address will be displayed in your HoloLens view 

OR 

Go to the headset settings :  

Settings/Network & Internet/Wi-Fi 
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Select the Wifi network to which the PC and HoloLens are connected 
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Click on Advanced Options and note the V4 IP address that appears at the bottom of 
the page (it is necessary to scroll to see it)  

 

 
 

Enter the V4 IP address in a web browser ( Chrome, Mozilla... We recommend you to 
use Google Chrome or Mozilla Firefox to use the Windows portal. Otherwise, you 
will need to install a certificate in the web browser settings. Also, a shared 
connection with your phone is recommended if you are using a secure corporate Wi-
Fi. ) 
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Skip the security alerts, click on "Advanced settings" and then click on "Continue to 
dangerous site". 
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 Enter the login and password that were defined during your first connection. 

 

 

 

 

 

 

 

 

 

 

 

Go to System> File Explorer 
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Go to « Documents » 

 

 
 

Create a new folder → " Create New Folder ", Rename your folder and click on " OK 
". 
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Go to your new folder, click on "Choose a file" to import your .nbim file
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Click on "Upload" to finalise the import of the file. Your .nbim file is imported. 
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